Install RuneScape NXT client in Ubuntu 18.04


#1

To install RuneScape NXT client in Ubuntu 18.04, run following commands as user root.

First become user root with command

sudo su

Now run following commands one by one

echo "deb http://archive.ubuntu.com/ubuntu/ trusty main" > /etc/apt/sources.list.d/ubuntu_14.04_aka_trusty.temp.list
apt-get update
apt-get -y install libglew1.10 libpng12-0
rm /etc/apt/sources.list.d/ubuntu_14.04_aka_trusty.temp.list
apt-get -y install libcurl3
wget -O - https://content.runescape.com/downloads/ubuntu/runescape.gpg.key | apt-key add -
echo "deb [trusted=yes] https://content.runescape.com/downloads/ubuntu trusty non-free" > /etc/apt/sources.list.d/runescape.list
apt-get update
apt-get install -y runescape-launcher

Jagex need to update their game client and fix GPG key for the repository. Every time i do apt update, i get annoying GPG key error, i disabled RuneScape apt repository with

mv /etc/apt/sources.list.d/runescape.list /etc/apt/sources.list.d/runescape.list.disabled

This won’t get you updated RuneScape client, that jagex never update. So no big issue, you can re enable if they ever managed to do an update to Game client.


#2

Ubuntu 18.04 have libcur3 and libcur4. Some applications require libcurl4, if you install libcurl4, libcurl3 get uninstalled and RuneScape client will stop working with error

[email protected]:~$ runescape-launcher 
/usr/share/games/runescape-launcher/runescape: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /usr/share/games/runescape-launcher/runescape)
[email protected]:~$

To fix this error, download

https://launchpad.net/ubuntu/+source/curl3/7.58.0-2ubuntu2/+build/14426633/+files/libcurl3_7.58.0-2ubuntu2_amd64.deb

Extract the file, inside you will see data.tar.xz, extract that. Go to folder data/usr/lib/x86_64-linux-gnu, copy libcurl.so.4.5.0 to folder ~/Jagex/lib

mkdir ~/Jagex/lib
cp libcurl.so.4.5.0 ~/Jagex/lib
cd ~/Jagex/lib
ln -s libcurl.so.4.5.0 libcurl.so.4

Now edit the launcher file

sudo gedit /usr/bin/runescape-launcher

Add fllowing line

export LD_LIBRARY_PATH=$HOME/Jagex/lib

Here is how my /usr/bin/runescape-launcher after the edit.

[email protected]:~$ cat /usr/bin/runescape-launcher
#!/bin/sh

if [ -z $1 ]; then
    configURI=http://www.runescape.com/k=5/l=\$\(Language:0\)/jav_config.ws
else
    configURI=$1
    shift
fi

export LD_LIBRARY_PATH=$HOME/Jagex/lib
export PULSE_PROP_OVERRIDE="application.name='RuneScape' application.icon_name='runescape' media.role='game'"
export SDL_VIDEO_X11_WMCLASS="RuneScape"
export MESA_GL_VERSION_OVERRIDE=3.0
unset XMODIFIERS
/usr/share/games/runescape-launcher/runescape --configURI $configURI [email protected]
[email protected]:~$